F5 Networks BIG-IP : PHP vulnerability (SOL9761)

Critical Nessus Plugin ID 78229

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

A heap-based buffer overflow in PHP 4.3.0 through 5.2.6 may allow attackers to execute arbitrary code.

Solution

Upgrade to one of the non-vulnerable versions listed in the F5 Solution SOL9761.

See Also

https://support.f5.com/csp/article/K9761

Plugin Details

Severity: Critical

ID: 78229

File Name: f5_bigip_SOL9761.nasl

Version: 1.6

Type: local

Published: 2014/10/10

Updated: 2019/01/04

Dependencies: 76940

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:f5:big-ip_application_security_manager, cpe:/h:f5:big-ip

Required KB Items: Host/local_checks_enabled, Host/BIG-IP/hotfix, Host/BIG-IP/modules, Host/BIG-IP/version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/03/12

Reference Information

CVE: CVE-2008-5557

BID: 32948

CWE: 119