HP Printers Security Bypass (HPSBPI03107)

Medium Nessus Plugin ID 78110


The remote printer is affected by a security bypass vulnerability.


The remote HP printer is affected by a security bypass vulnerability.
The included OpenSSL library has a security bypass flaw in the handshake process. By using a specially crafted handshake, a remote attacker can force the use of weak keying material. This could be leveraged for a man-in-the-middle attack.


Upgrade the firmware in accordance with the vendor's advisory.

See Also


Plugin Details

Severity: Medium

ID: 78110

File Name: hp_laserjet_hpsbpi03107.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Misc.

Published: 2014/10/09

Modified: 2016/12/21

Dependencies: 36128, 58184

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/h:hp:laserjet

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/07/22

Vulnerability Publication Date: 2014/06/03

Exploitable With

Core Impact

Reference Information

CVE: CVE-2014-0224

BID: 67899

OSVDB: 107729

CERT: 978508

HP: emr_na-c04451722, HPSBPI03107