Apache Subversion 1.0.x - 1.7.17 / 1.8.x < 1.8.10 Multiple Vulnerabilities

medium Nessus Plugin ID 78068
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host has an application that is affected by multiple vulnerabilities.


The version of Subversion Server installed on the remote host is version 1.x.x prior to 1.7.18 or 1.8.x prior to 1.8.10. It is, therefore, affected by the following vulnerabilities :

- A flaw exists in the Serf RA layer. This flaw causes wildcards for HTTPS connections to be improperly evaluated, which may result in the application accepting certificates that are not matched against the proper hostname. This may allow a remote man-in-the-middle attacker to intercept traffic and spoof valid sessions. (CVE-2014-3522)

- An MD5 hash of the URL and authentication realm are used to store cached credentials, which may allow remote attackers to obtain these credentials via a specially crafted authentication realm. (CVE-2014-3528)


Upgrade to Subversion Server 1.7.18 / 1.8.10 or later, or apply the vendor-supplied patch or workaround.

See Also



Plugin Details

Severity: Medium

ID: 78068

File Name: subversion_1_8_10.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 10/6/2014

Updated: 7/30/2018

Dependencies: subversion_installed.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 4.7


Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:H/Au:N/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:subversion

Required KB Items: installed_sw/Subversion Server, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 8/19/2014

Vulnerability Publication Date: 8/19/2014

Reference Information

CVE: CVE-2014-3522, CVE-2014-3528

BID: 68995, 69237