Apache Subversion 1.0.x - 1.7.17 / 1.8.x < 1.8.10 Multiple Vulnerabilities

Medium Nessus Plugin ID 78068


The remote host has an application that is affected by multiple vulnerabilities.


The version of Subversion Server installed on the remote host is version 1.x.x prior to 1.7.18 or 1.8.x prior to 1.8.10. It is, therefore, affected by the following vulnerabilities :

- A flaw exists in the Serf RA layer. This flaw causes wildcards for HTTPS connections to be improperly evaluated, which may result in the application accepting certificates that are not matched against the proper hostname. This may allow a remote man-in-the-middle attacker to intercept traffic and spoof valid sessions. (CVE-2014-3522)

- An MD5 hash of the URL and authentication realm are used to store cached credentials, which may allow remote attackers to obtain these credentials via a specially crafted authentication realm. (CVE-2014-3528)


Upgrade to Subversion Server 1.7.18 / 1.8.10 or later, or apply the vendor-supplied patch or workaround.

See Also



Plugin Details

Severity: Medium

ID: 78068

File Name: subversion_1_8_10.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2014/10/06

Modified: 2016/05/13

Dependencies: 40619

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:apache:subversion

Required KB Items: installed_sw/Subversion Server, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/08/19

Vulnerability Publication Date: 2014/08/19

Reference Information

CVE: CVE-2014-3522, CVE-2014-3528

BID: 68995, 69237

OSVDB: 109748, 109996