SeaMonkey < 2.29.1 NSS Signature Verification Vulnerability

High Nessus Plugin ID 77909


The remote Windows host contains a web browser that is affected by a signature forgery vulnerability.


The version of SeaMonkey installed on the remote host is prior to 2.29.1. It is, therefore, affected by a flaw in the Network Security Services (NSS) library, which is due to lenient parsing of ASN.1 values involved in a signature and can lead to the forgery of RSA signatures, such as SSL certificates.


Upgrade to SeaMonkey 2.29.1 or later.

See Also

Plugin Details

Severity: High

ID: 77909

File Name: seamonkey_2_29_1.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2014/09/26

Modified: 2017/06/12

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 8.8

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:mozilla:seamonkey

Required KB Items: SeaMonkey/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/09/24

Vulnerability Publication Date: 2014/09/24

Reference Information

CVE: CVE-2014-1568

BID: 70116

OSVDB: 112036

CERT: 772676