Mozilla Thunderbird < 31.1.2 NSS Signature Verification Vulnerability

High Nessus Plugin ID 77908

Synopsis

The remote Windows host contains a mail client that is affected by a signature forgery vulnerability.

Description

The version of Thunderbird installed on the remote host is prior to 31.1.2. It is, therefore, affected by a flaw in the Network Security Services (NSS) library, which is due to lenient parsing of ASN.1 values involved in a signature and can lead to the forgery of RSA signatures, such as SSL certificates.

Solution

Upgrade to Thunderbird 31.1.2 or later.

See Also

https://www.mozilla.org/security/announce/2014/mfsa2014-73.html

Plugin Details

Severity: High

ID: 77908

File Name: mozilla_thunderbird_31_1_2.nasl

Version: 1.7

Type: local

Agent: windows

Family: Windows

Published: 2014/09/26

Updated: 2019/11/25

Dependencies: 20862

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2014-1568

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:thunderbird

Required KB Items: Mozilla/Thunderbird/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/09/24

Vulnerability Publication Date: 2014/09/24

Reference Information

CVE: CVE-2014-1568

BID: 70116

CERT: 772676