GLSA-201409-10 : Bash: Code Injection (Updated fix for GLSA 201409-09)

Critical Nessus Plugin ID 77886

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201409-10 (Bash: Code Injection (Updated fix for GLSA 201409-09))

Stephane Chazelas reported that Bash incorrectly handles function definitions, allowing attackers to inject arbitrary code (CVE-2014-6271).
Gentoo Linux informed about this issue in GLSA 201409-09.
Tavis Ormandy reported that the patch for CVE-2014-6271 was incomplete.
As such, this GLSA supersedes GLSA 201409-09.
Impact :

A remote attacker could exploit this vulnerability to execute arbitrary commands even in restricted environments.
Workaround :

There is no known workaround at this time.

Solution

All Bash 3.1 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-shells/bash-3.1_p18-r1:3.1' All Bash 3.2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-shells/bash-3.2_p52-r1:3.2' All Bash 4.0 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-shells/bash-4.0_p39-r1:4.0' All Bash 4.1 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-shells/bash-4.1_p12-r1:4.1' All Bash 4.2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-shells/bash-4.2_p48-r1'

See Also

https://security.gentoo.org/glsa/201409-10

Plugin Details

Severity: Critical

ID: 77886

File Name: gentoo_GLSA-201409-10.nasl

Version: Revision: 1.10

Type: local

Published: 2014/09/26

Updated: 2015/04/14

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:bash, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/09/25

Reference Information

CVE: CVE-2014-7169

BID: 70137

GLSA: 201409-10

IAVA: 2014-A-0142