GNU Bash Local Environment Variable Handling Command Injection via Telnet (CVE-2014-7169) (Shellshock)

Critical Nessus Plugin ID 77857


A system shell on the remote host is vulnerable to command injection.


The remote host is running a version of Bash that is vulnerable to command injection via environment variable manipulation. Depending on the configuration of the system, an attacker could remotely execute arbitrary code.


Update Bash.

See Also

Plugin Details

Severity: Critical

ID: 77857

File Name: bash_remote_code_execution_telnet.nasl

Version: $Revision: 1.15 $

Type: remote

Published: 2014/09/25

Modified: 2017/04/25

Dependencies: 10280, 17975

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:gnu:bash

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Patch Publication Date: 2014/09/24

Vulnerability Publication Date: 2014/09/24

Exploitable With

Metasploit (Apache mod_cgi Bash Environment Variable Code Injection (Shellshock))

Reference Information

CVE: CVE-2014-7169

BID: 70137

OSVDB: 112004

CERT: 252743

IAVA: 2014-A-0142

EDB-ID: 34765, 34766, 34777