IDA Pro Multiple Memory Corruption Vulnerabilities

Medium Nessus Plugin ID 77750


The remote host has an application installed that is affected by memory corruption vulnerabilities.


The version of IDA Pro, an interactive disassembler installed on the remote host, is 6.5 or 6.6. It is, therefore, affected by memory corruption vulnerabilities.

These vulnerabilities are mitigated by updated IDA loaders, which were not detected.

By tricking a user into loading a specially crafted IDB (IDA database) file into IDA Pro, an attacker can cause a denial of service or execute arbitrary code or have other unspecified impact.


Install the fix provided by the vendor.

See Also

Plugin Details

Severity: Medium

ID: 77750

File Name: ida_pro_multiple_vulns.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2014/09/18

Modified: 2014/09/19

Dependencies: 13855

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:datarescue:ida_pro

Required KB Items: SMB/Registry/Enumerated

Patch Publication Date: 2014/09/12

Vulnerability Publication Date: 2014/09/12

Reference Information

OSVDB: 111541, 111463, 111462, 111461, 111460

IAVB: 2014-B-0125