phpMyAdmin 4.0.x < 4.0.10.3 / 4.1.x < 4.1.14.4 / 4.2.x < 4.2.8.1 Micro History XSS and XSRF Vulnerabilities (PMASA-2014-10)

medium Nessus Plugin ID 77702

Synopsis

The remote web server hosts a PHP application that is affected by cross-site scripting and cross-site request forgery vulnerabilities.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.0.x prior to 4.0.10.3, 4.1.x prior to 4.1.14.4, or 4.2.x prior to 4.2.8.1. It is, therefore, affected by an input-validation error related to the 'micro history' feature that could allow a DOM-based cross-site scripting attack that could further lead to cross-site request forgery attacks.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin 4.0.10.3 / 4.1.14.4 / 4.2.8.1 or later, or apply the patches from the referenced links.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2014-10.php

http://www.nessus.org/u?8ef26e90

Plugin Details

Severity: Medium

ID: 77702

File Name: phpmyadmin_pmasa_2014_10.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 9/16/2014

Updated: 4/11/2022

Configuration: Enable paranoid mode, Enable thorough checks

Risk Information

VPR

Risk Factor: Low

Score: 2.7

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2014-6300

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, www/phpMyAdmin, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/13/2014

Vulnerability Publication Date: 9/13/2014

Reference Information

CVE: CVE-2014-6300

BID: 69790

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990