Mandriva Linux Security Advisory : gpgme (MDVSA-2014:160)

Medium Nessus Plugin ID 77639


The remote Mandriva Linux host is missing one or more security updates.


Updated gpgme packages fix security vulnerability :

A heap-based buffer overflow in gpgme before 1.5.1 could allow a specially crafted certificate to cause crashes or potentially cause arbitrary code execution (CVE-2014-3564).


Update the affected lib64gpgme-devel and / or lib64gpgme11 packages.

See Also

Plugin Details

Severity: Medium

ID: 77639

File Name: mandriva_MDVSA-2014-160.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2014/09/12

Modified: 2014/10/23

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64gpgme-devel, p-cpe:/a:mandriva:linux:lib64gpgme11, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/09/02

Reference Information

CVE: CVE-2014-3564

BID: 68990

MDVSA: 2014:160