Apache 2.2.x < 2.2.28 Multiple Vulnerabilities

High Nessus Plugin ID 77531


The remote web server is affected by multiple vulnerabilities.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.28. It is, therefore, affected by the following vulnerabilities :

- A flaw exists within the 'mod_headers' module which allows a remote attacker to inject arbitrary headers.
This is done by placing a header in the trailer portion of data being sent using chunked transfer encoding.

- A flaw exists within the 'mod_deflate' module when handling highly compressed bodies. Using a specially crafted request, a remote attacker can exploit this to cause a denial of service by exhausting memory and CPU resources. (CVE-2014-0118)

- The 'mod_status' module contains a race condition that can be triggered when handling the scoreboard. A remote attacker can exploit this to cause a denial of service, execute arbitrary code, or obtain sensitive credential information. (CVE-2014-0226)

- The 'mod_cgid' module lacks a time out mechanism. Using a specially crafted request, a remote attacker can use this flaw to cause a denial of service by causing child processes to linger indefinitely, eventually filling up the scoreboard. (CVE-2014-0231)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache version 2.2.29 or later.

Note that version 2.2.28 was never officially released.

See Also





Plugin Details

Severity: High

ID: 77531

File Name: apache_2_2_29.nasl

Version: $Revision: 1.10 $

Type: remote

Family: Web Servers

Published: 2014/09/04

Modified: 2018/03/02

Dependencies: 48204

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/09/03

Vulnerability Publication Date: 2014/03/31

Reference Information

CVE: CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231

BID: 66550, 68678, 68742, 68745

OSVDB: 105190, 109216, 109231, 109234

EDB-ID: 34133