Mozilla Thunderbird 24.x < 24.8 Multiple Vulnerabilities

High Nessus Plugin ID 77501


The remote Windows host contains a mail client that is affected by multiple vulnerabilities.


The version of Thunderbird 24.x installed on the remote host is a version prior to 24.8. It is, therefore, affected by the following vulnerabilities :

- Multiple memory safety flaws exist within the browser engine. Exploiting these, an attacker can cause a denial of service or execute arbitrary code. (CVE-2014-1562)

- A use-after-free vulnerability exists due to improper handling of text layout in directionality resolution.
A remote attacker can exploit this to execute arbitrary code. (CVE-2014-1567)


Upgrade to Thunderbird 24.8 or later.

See Also

Plugin Details

Severity: High

ID: 77501

File Name: mozilla_thunderbird_24_8.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2014/09/03

Modified: 2014/10/03

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:thunderbird

Required KB Items: Mozilla/Thunderbird/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/09/02

Vulnerability Publication Date: 2014/09/02

Reference Information

CVE: CVE-2014-1562, CVE-2014-1567

BID: 69519, 69520