Debian DSA-3012-1 : eglibc - security update

high Nessus Plugin ID 77418
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Tavis Ormandy discovered a heap-based buffer overflow in the transliteration module loading code in eglibc, Debian's version of the GNU C Library. As a result, an attacker who can supply a crafted destination character set argument to iconv-related character conversation functions could achieve arbitrary code execution.

This update removes support of loadable gconv transliteration modules.
Besides the security vulnerability, the module loading code had functionality defects which prevented it from working for the intended purpose.

Solution

Upgrade the eglibc packages.

For the stable distribution (wheezy), this problem has been fixed in version 2.13-38+deb7u4.

See Also

https://packages.debian.org/source/wheezy/eglibc

https://www.debian.org/security/2014/dsa-3012

Plugin Details

Severity: High

ID: 77418

File Name: debian_DSA-3012.nasl

Version: 1.13

Type: local

Agent: unix

Published: 8/28/2014

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:eglibc, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/27/2014

Reference Information

CVE: CVE-2014-5119

BID: 68983

DSA: 3012