nginx < 1.6.1 / 1.7.4 SMTP STARTTLS Command Injection

Medium Nessus Plugin ID 77246


The remote web server is affected by a command injection vulnerability.


According to the self-reported version in the server response header, the version of nginx installed on the remote host is 1.5.6 or higher, 1.6.x prior to 1.6.1, or 1.7.x prior to 1.7.4. It is, therefore, affected by a command injection vulnerability.

A flaw exists in the function 'ngx_mail_smtp_starttls' within the file 'src/mail/ngx_mail_smtp_handler.c' whereby input to the STARTTLS command is not properly sanitized. This could allow a remote attacker in a privileged network position to obtain sensitive information by injecting commands into an SSL session.

Note that this issue is exploitable only when nginx is used as an SMTP proxy.


Apply the patch manually, or upgrade to nginx 1.6.1 / 1.7.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 77246

File Name: nginx_1_7_4.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Web Servers

Published: 2014/08/19

Modified: 2018/01/26

Dependencies: 106375

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/08/05

Vulnerability Publication Date: 2014/08/05

Reference Information

CVE: CVE-2014-3556

BID: 69111

OSVDB: 109849