Splunk Enterprise 6.1.x < 6.1.3 Multiple Vulnerabilities

medium Nessus Plugin ID 77238


The remote web server contains an application that is affected by multiple vulnerabilities.


According to its version number, the Splunk Enterprise hosted on the remote web server is 6.1.x prior to 6.1.3. It is, therefore, affected by the following vulnerabilities :

- A path traversal vulnerability exists due to a flaw related to search IDs, in which user input is not properly sanitized. A remote, authenticated attacker can exploit this, via a specially crafted URL, to read arbitrary files outside the restricted path.

- A cross-site scripting vulnerability exists due to the referrer header not being properly validated before returning it to users. A remote attacker can exploit this, via a specially crafted request, to execute script code in a user's browser session. (CVE-2014-5198)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Splunk Enterprise 6.1.3 or later.

See Also


Plugin Details

Severity: Medium

ID: 77238

File Name: splunk_613.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 8/18/2014

Updated: 1/19/2021

Risk Information


Risk Factor: Low

Score: 3.4


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Ease: No exploit is required

Patch Publication Date: 8/4/2014

Vulnerability Publication Date: 8/4/2014

Reference Information

CVE: CVE-2014-5197, CVE-2014-5198

BID: 69234

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990