Drupal 6.x < 6.33 / 7.x < 7.31 XML-RPC DoS

medium Nessus Plugin ID 77186
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server is running a PHP application that is affected by denial of service vulnerabilities.


The remote web server is running a version of Drupal that is 6.x prior to 6.33 or 7.x prior to 7.31. It is, therefore, potentially affected by multiple denial of service vulnerabilities :

- The XML-RPC library in Drupal allows entity declarations without considering recursion during entity expansion.
A remote attacker, using a crafted XML document with a large number of nested entity references, can cause a denial of service by consuming available memory and CPU resources. (CVE-2014-5265)

- The XML-RPC library in Drupal does not limit the number of elements in an XML document. A remote attacker, via a large document, could cause a denial of service by CPU consumption. (CVE-2014-5266)

- An XML injection flaw exists in 'xmlrpc.php' due to the parser accepting XML internal entities from untrusted sources. A remote attacker, via specially crafted XML data, could exploit this to cause a denial of service.
This vulnerability also exists within the Drupal OpenID module.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to version 6.33 / 7.31 or later.

See Also




Plugin Details

Severity: Medium

ID: 77186

File Name: drupal_7_31.nasl

Version: 1.14

Type: remote

Family: CGI abuses

Published: 8/13/2014

Updated: 1/19/2021

Dependencies: drupal_detect.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: www/PHP, installed_sw/Drupal, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 8/6/2014

Vulnerability Publication Date: 8/6/2014

Reference Information

CVE: CVE-2014-5265, CVE-2014-5266

BID: 69146