MS14-046: Vulnerability in .NET Framework Could Allow Security Feature Bypass (2984625)

Medium Nessus Plugin ID 77164


The version of the .NET Framework installed on the remote host is affected by a security feature bypass vulnerability.


The remote Windows host has a version of the Microsoft .NET Framework that is affected by a vulnerability that could allow an attacker to bypass the Address Space Layout Randomization (ASLR) security feature.


Microsoft has released a set of patches for .NET Framework 2.0 SP2, 3.0 SP2, 3.5, and 3.5.1.

See Also

Plugin Details

Severity: Medium

ID: 77164

File Name: smb_nt_ms14-046.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Published: 2014/08/12

Modified: 2017/07/28

Dependencies: 13855, 57033

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:microsoft:.net_framework

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/08/12

Vulnerability Publication Date: 2014/08/12

Reference Information

CVE: CVE-2014-4062

BID: 69145

OSVDB: 109937

MSFT: MS14-046

MSKB: 2937608, 2943344, 2966825, 2966827, 2966826, 2966828, 2937610, 2943357

IAVA: 2014-A-0128