Mandriva Linux Security Advisory : ipython (MDVSA-2014:157)

Medium Nessus Plugin ID 77096


The remote Mandriva Linux host is missing a security update.


Updated ipython package fixes security vulnerability :

In IPython before 1.2, the origin of websocket requests was not verified within the IPython notebook server. If an attacker has knowledge of an IPython kernel id they can run arbitrary code on a user's machine when the client visits a crafted malicious page (CVE-2014-3429).


Update the affected ipython package.

See Also

Plugin Details

Severity: Medium

ID: 77096

File Name: mandriva_MDVSA-2014-157.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2014/08/09

Modified: 2014/08/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ipython, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/08/08

Reference Information

CVE: CVE-2014-3429

BID: 68680

MDVSA: 2014:157