VMware vCenter Converter Multiple Vulnerabilities (VMSA-2014-0006)

medium Nessus Plugin ID 76947
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has an application installed that is affected by multiple vulnerabilities.

Description

The version of VMware vCenter Converter installed on the remote Windows host is version 5.1.x prior to 5.1.1 or 5.5.x prior to 5.5.2.
It is, therefore, affected by multiple vulnerabilities in the bundled OpenSSL library :

- An error exists in the function 'ssl3_read_bytes' that could allow data to be injected into other sessions or allow denial of service attacks. Note this issue is only exploitable if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298)

- A buffer overflow error exists related to invalid DTLS fragment handling that could lead to execution of arbitrary code. Note this issue only affects OpenSSL when used as a DTLS client or server. (CVE-2014-0195)

- An error exists in the function 'do_ssl3_write' that could allow a NULL pointer to be dereferenced leading to denial of service attacks. Note this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2014-0198)

- An error exists related to DTLS handshake handling that could lead to denial of service attacks. Note this issue only affects OpenSSL when used as a DTLS client.
(CVE-2014-0221)

- An unspecified error exists that could allow an attacker to cause usage of weak keying material leading to simplified man-in-the-middle attacks.
(CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH cipher suites that could allow denial of service attacks. Note this issue only affects OpenSSL TLS clients. (CVE-2014-3470)

Solution

Upgrade to VMware vCenter Converter 5.1.1, 5.5.2, or later.

See Also

http://www.vmware.com/security/advisories/VMSA-2014-0006.html

https://www.openssl.org/news/secadv/20140605.txt

Plugin Details

Severity: Medium

ID: 76947

File Name: vmware_vcenter_converter_2014-0006.nasl

Version: 1.11

Type: local

Agent: windows

Family: Windows

Published: 7/31/2014

Updated: 11/25/2019

Dependencies: vmware_vcenter_converter_installed.nbin

Risk Information

CVSS Score Source: CVE-2014-0195

VPR

Risk Factor: High

Score: 7.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_converter

Required KB Items: installed_sw/VMware vCenter Converter

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/24/2014

Vulnerability Publication Date: 6/10/2014

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-5298, CVE-2014-0195, CVE-2014-0198, CVE-2014-0221, CVE-2014-0224, CVE-2014-3470

BID: 66801, 67193, 67898, 67899, 67900, 67901

CERT: 978508

IAVB: 2014-B-0102

VMSA: 2014-0006