Mandriva Linux Security Advisory : owncloud (MDVSA-2014:140)

medium Nessus Plugin ID 76886
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Mandriva Linux host is missing a security update.

Description

Updated owncloud package fixes security vulnerability :

In ownCloud before 5.0.17 and 6.0.4, there exists a limited local file inclusion vulnerability due to an improper control of the filename for a require_once() statement in the routing component (CVE-2014-4929).

See the upstream Changelog for more information.

Solution

Update the affected owncloud package.

See Also

http://advisories.mageia.org/MGASA-2014-0301.html

http://owncloud.org/security/advisory/?id=oc-sa-2014-018

https://owncloud.org/changelog/

Plugin Details

Severity: Medium

ID: 76886

File Name: mandriva_MDVSA-2014-140.nasl

Version: 1.8

Type: local

Published: 7/30/2014

Updated: 1/6/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:owncloud, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 7/29/2014

Reference Information

CVE: CVE-2014-4929

BID: 68975

MDVSA: 2014:140