HP OneView < 1.10 OpenSSL Multiple Vulnerabilities (HPSBGN03068)

Medium Nessus Plugin ID 76776

Synopsis

The remote host has an application installed that is affected by multiple OpenSSL related vulnerabilities.

Description

The version of HP OneView installed on the remote host is 1.0, 1.01, or 1.05. It is, therefore, affected by the following vulnerabilities related to the included OpenSSL libraries :

- An error exists in the function 'ssl3_read_bytes' that could allow data to be injected into other sessions or allow denial of service attacks. Note this issue is only exploitable if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298)

- An error exists in the function 'do_ssl3_write' that could allow a NULL pointer to be dereferenced leading to denial of service attacks. Note this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2014-0198)

- An unspecified error exists that could allow an attacker to cause usage of weak keying material leading to simplified man-in-the-middle attacks.
(CVE-2014-0224)

Solution

Upgrade to HP OneView 1.10 or later.

See Also

http://www.nessus.org/u?4400eebb

https://www.securityfocus.com/archive/1/532783/30/0/threaded

Plugin Details

Severity: Medium

ID: 76776

File Name: hp_oneview_1_10.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 2014/07/24

Updated: 2018/11/28

Dependencies: 76054

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:hp:oneview

Required KB Items: www/hp_oneview

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/07/09

Vulnerability Publication Date: 2010/02/09

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-5298, CVE-2014-0198, CVE-2014-0224

BID: 66801, 67193, 67899

CERT: 978508

HP: emr_na-c04368264, HPSBGN03068, SSRT101004