HP OneView < 1.10 OpenSSL Multiple Vulnerabilities (HPSBGN03068)

Medium Nessus Plugin ID 76776

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 8.5


The remote host has an application installed that is affected by multiple OpenSSL related vulnerabilities.


The version of HP OneView installed on the remote host is 1.0, 1.01, or 1.05. It is, therefore, affected by the following vulnerabilities related to the included OpenSSL libraries :

- An error exists in the function 'ssl3_read_bytes' that could allow data to be injected into other sessions or allow denial of service attacks. Note this issue is only exploitable if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298)

- An error exists in the function 'do_ssl3_write' that could allow a NULL pointer to be dereferenced leading to denial of service attacks. Note this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2014-0198)

- An unspecified error exists that could allow an attacker to cause usage of weak keying material leading to simplified man-in-the-middle attacks.


Upgrade to HP OneView 1.10 or later.

See Also



Plugin Details

Severity: Medium

ID: 76776

File Name: hp_oneview_1_10.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 2014/07/24

Updated: 2019/11/26

Dependencies: 76054

Risk Information

Risk Factor: Medium

VPR Score: 8.5

CVSS Score Source: CVE-2014-0224

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:hp:oneview

Required KB Items: www/hp_oneview

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/07/09

Vulnerability Publication Date: 2010/02/09

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-5298, CVE-2014-0198, CVE-2014-0224

BID: 66801, 67193, 67899

CERT: 978508

HP: emr_na-c04368264, HPSBGN03068, SSRT101004