PHP 5.5.x < 5.5.15 Multiple Vulnerabilities

medium Nessus Plugin ID 76772
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.5.x in use on the remote web server is a version prior to 5.5.15. It is, therefore, affected by the following vulnerabilities :

- A use-after-free error exists in the file 'ext/spl/spl_dllist.c' related to the Standard PHP Library (SPL). Using a specially crafted iterator, an attacker could cause a denial of service condition or other unspecified impacts. (CVE-2014-4670)

- A use-after-free error exists in the file 'ext/spl/spl_array.c' related to the Standard PHP Library (SPL). This could allow an attacker, using 'ArrayObjects' or 'ArrayIterator', to cause a denial of service condition or other unspecified impacts.
(CVE-2014-4698)

- The function 'sapi_cli_server_send_headers' in the file 'sapi/cli/php_cli_server.c' contains an error that does not properly handle an empty 'header' parameter and could allow denial of service attacks. Note that this issue affects only the built-in command line development server.

Note that Nessus has not attempted to exploit these issues, but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.5.15 or later.

See Also

https://bugs.php.net/bug.php?id=67539

https://bugs.php.net/bug.php?id=67538

https://bugs.php.net/bug.php?id=66830

http://www.php.net/ChangeLog-5.php#5.5.15

Plugin Details

Severity: Medium

ID: 76772

File Name: php_5_5_15.nasl

Version: 1.13

Type: remote

Family: CGI abuses

Published: 7/25/2014

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2014-4698

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 7/24/2014

Vulnerability Publication Date: 3/5/2014

Reference Information

CVE: CVE-2014-4670, CVE-2014-4698

BID: 68511, 68513