HP Smart Update Manager 6.x < 6.4.1 Multiple Vulnerabilities

medium Nessus Plugin ID 76769
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running software that is affected by multiple vulnerabilities.

Description

The version of HP Smart Update manager running on the remote host is prior to 6.4.1. It is, therefore, affected by the following vulnerabilities :

- An error exists in the function 'ssl3_read_bytes' that can allow data to be injected into other sessions or allow denial of service attacks. Note that this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298)

- A buffer overflow error exists related to invalid DTLS fragment handling that can lead to the execution of arbitrary code. Note that this issue only affects OpenSSL when used as a DTLS client or server.
(CVE-2014-0195)

- An error exists in the function 'do_ssl3_write' that can allow a NULL pointer to be dereferenced leading to denial of service attacks. Note that this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2014-0198)

- An error exists related to DTLS handshake handling that can lead to denial of service attacks. Note that this issue only affects OpenSSL when used as a DTLS client.
(CVE-2014-0221)

- An unspecified error exists in how ChangeCipherSpec messages are processed that can allow an attacker to cause usage of weak keying material, leading to simplified man-in-the-middle attacks. (CVE-2014-0224)

- An unspecified flaw exists that allows a local attacker to disclose sensitive information. Note that if the host OS is Linux based, only versions 6.2.0, 6.3.0, 6.3.1, and 6.4.0 suffer from this flaw. (CVE-2014-2608)

- An unspecified error exists related to anonymous ECDH cipher suites that can allow denial of service attacks.
Note that this issue only affects OpenSSL TLS clients.
(CVE-2014-3470)

Solution

Upgrade to HP Smart Update Manager 6.4.1 or later.

See Also

http://www.nessus.org/u?4eed8378

https://www.openssl.org/news/secadv/20140605.txt

http://www.nessus.org/u?fcd9bd2a

Plugin Details

Severity: Medium

ID: 76769

File Name: hp_sum_6_4_1.nasl

Version: 1.13

Type: remote

Family: CGI abuses

Published: 7/24/2014

Updated: 1/19/2021

Dependencies: hp_sum_detect.nbin

Risk Information

CVSS Score Source: CVE-2014-0195

VPR

Risk Factor: High

Score: 7.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:hp:smart_update_manager

Required KB Items: installed_sw/HP Smart Update Manager

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/9/2014

Vulnerability Publication Date: 4/11/2014

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-5298, CVE-2014-0195, CVE-2014-0198, CVE-2014-0221, CVE-2014-0224, CVE-2014-2608, CVE-2014-3470

BID: 66801, 67193, 67898, 67899, 67900, 67901, 71613

CERT: 978508

HP: emr_na-c04349175, HPSBMU03055, SSRT101616, emr_na-c04302476, HPSBMU03043, SSRT101578