Mozilla Thunderbird < 31.0 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 76761


The remote Mac OS X host contains a mail client that is affected by multiple vulnerabilities.


The version of Thunderbird installed on the remote host is a version prior to 31.0. It is, therefore, affected by the following vulnerabilities :

- When a pair of NSSCertificate structures are added to a trust domain and then one of them is removed during use, a use-after-free error occurs which may cause the application to crash. This crash is potentially exploitable. (CVE-2014-1544)

- There are multiple memory safety hazards within the browser engine. These hazards may lead to memory corruption vulnerabilities, which may allow attackers to execute arbitrary code. (CVE-2014-1547, CVE-2014-1548)

- A buffer overflow exists when interacting with the Web Audio buffer during playback due to an error with the allocation of memory for the buffer. This may lead to a potentially exploitable crash. (CVE-2014-1549)

- A use-after-free exists in Web Audio due to the way control messages are handled. This may lead to a potentially exploitable crash. (CVE-2014-1550)

- There is an issue with the IFRAME sandbox same-origin access policy which allows sandboxed content to access other content from the same origin without approval.
This may lead to a same-origin-bypass vulnerability.

- Triggering the FireOnStateChange event has the potential to crash the application. This may lead to a use-after-free and an exploitable crash.

- When using the Cesium JavaScript library to generate WebGL content, the application may crash. This crash is potentially exploitable. (CVE-2014-1556)

- There is a flaw in the Skia library when scaling images of high quality. If the image data is discarded while being processed, the library may crash. This crash is potentially exploitable. (CVE-2014-1557)

- There are multiple issues with using invalid characters in various certificates. These invalid characters may cause certificates to be parsed incorrectly which may lead to the inability to use valid SSL certificates. (CVE-2014-1558, CVE-2014-1559, CVE-2014-1560)


Upgrade to Thunderbird 31.0 or later.

See Also

Plugin Details

Severity: High

ID: 76761

File Name: macosx_thunderbird_31_0.nasl

Version: $Revision: 1.4 $

Type: local

Agent: macosx

Published: 2014/07/24

Modified: 2016/05/17

Dependencies: 56557

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:thunderbird

Required KB Items: MacOSX/Thunderbird/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/07/22

Vulnerability Publication Date: 2014/07/22

Reference Information

CVE: CVE-2014-1544, CVE-2014-1547, CVE-2014-1548, CVE-2014-1549, CVE-2014-1550, CVE-2014-1552, CVE-2014-1555, CVE-2014-1557, CVE-2014-1558, CVE-2014-1559, CVE-2014-1560

BID: 68810, 68811, 68812, 68813, 68814, 68815, 68816, 68818, 68820, 68821, 68824

OSVDB: 109409, 109410, 109411, 109412, 109413, 109414, 109415, 109416, 109417, 109418, 109419, 109420, 109421, 109422, 109423, 109424, 109425, 109426, 109427, 109428, 109429, 109430, 109431, 109432, 109433, 109434, 109438, 109439