Apache 2.4.x < 2.4.10 Multiple Vulnerabilities

high Nessus Plugin ID 76622
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server may be affected by multiple vulnerabilities.


According to its banner, the version of Apache 2.4.x running on the remote host is prior to 2.4.10. It is, therefore, affected by the following vulnerabilities :

- A flaw exists in the 'mod_proxy' module that may allow an attacker to send a specially crafted request to a server configured as a reverse proxy that may cause the child process to crash. This could potentially lead to a denial of service attack. (CVE-2014-0117)

- A flaw exists in the 'mod_deflate' module when request body decompression is configured. This could allow a remote attacker to cause the server to consume significant resources. (CVE-2014-0118)

- A flaw exists in the 'mod_status' module when a publicly accessible server status page is in place.
This could allow an attacker to send a specially crafted request designed to cause a heap buffer overflow. (CVE-2014-0226)

- A flaw exists in the 'mod_cgid' module in which CGI scripts that did not consume standard input may be manipulated in order to cause child processes to hang. A remote attacker may be able to abuse this in order to cause a denial of service.

- A flaw exists in WinNT MPM versions 2.4.1 to 2.4.9 when using the default AcceptFilter. An attacker may be able to specially craft requests that create a memory leak in the application and may eventually lead to a denial of service attack. (CVE-2014-3523)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache version 2.4.10 or later. Alternatively, ensure that the affected modules are not in use.

See Also



Plugin Details

Severity: High

ID: 76622

File Name: apache_2_4_10.nasl

Version: 1.20

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 7/21/2014

Updated: 1/28/2021

Dependencies: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

Risk Information

CVSS Score Source: CVE-2014-0226


Risk Factor: Medium

Score: 6.7


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C


Risk Factor: High

Base Score: 7.3

Temporal Score: 6.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 7/21/2014

Vulnerability Publication Date: 7/15/2014

Reference Information

CVE: CVE-2014-0117, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231, CVE-2014-3523

BID: 68678, 68740, 68742, 68745, 68747

EDB-ID: 34133