Splunk Enterprise 4.3.x / 5.0.x < 5.0.9 / 6.0.x < 6.0.5 / 6.1.x < 6.1.2 Multiple OpenSSL Vulnerabilities

Medium Nessus Plugin ID 76528

Synopsis

The remote web server contains an application that is affected by multiple OpenSSL-related vulnerabilities.

Description

According to its version number, the Splunk Enterprise hosted on the remote web server is 4.3.x, 5.0.x prior to 5.0.9, 6.0.x prior to 6.0.5, or 6.1.x prior to 6.1.2. It is, therefore, affected by multiple OpenSSL-related vulnerabilities :

- An unspecified error exists that allows an attacker to cause usage of weak keying material, resulting in simplified man-in-the-middle attacks. (CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH cipher suites that allow denial of service attacks. Note that this issue only affects OpenSSL TLS clients.
(CVE-2014-3470)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Splunk Enterprise 5.0.9 / 6.0.5 / 6.1.2 or later as appropriate.

See Also

https://www.splunk.com/view/SP-CAAAM2D

http://www.nessus.org/u?e0aaf276

https://www.openssl.org/news/secadv/20140605.txt

Plugin Details

Severity: Medium

ID: 76528

File Name: splunk_605.nasl

Version: 1.12

Type: remote

Family: Web Servers

Published: 2014/07/16

Updated: 2019/11/26

Dependencies: 49069, 47619

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2014-0224

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/07/01

Vulnerability Publication Date: 2014/06/05

Exploitable With

Core Impact

Reference Information

CVE: CVE-2014-0224, CVE-2014-3470

BID: 67898, 67899

CERT: 978508