Apache mod_wsgi < 3.5 Apache Process Privilege Escalation

high Nessus Plugin ID 76497
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server module is affected by a privilege escalation vulnerability.


According to the web server banner, the version of mod_wsgi running on the remote host is prior to version 3.5. It is, therefore, affected by a privilege escalation vulnerability.

The issue occurs due to the improper handling of error codes returned by 'setuid'. This flaw allows local attackers to manipulate the number of processes that are run by the user to affect the outcome of 'setuid' during the forking of daemon mode processes. This could allow the attacker to gain elevated privileges.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to mod_wsgi 3.5 or later.

See Also


Plugin Details

Severity: High

ID: 76497

File Name: mod_wsgi_3_5.nasl

Version: 1.6

Type: remote

Family: Web Servers

Published: 7/14/2014

Updated: 11/15/2018

Dependencies: apache_http_version.nasl

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6.2

Temporal Score: 4.6

Vector: AV:L/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:modwsgi:mod_wsgi

Required KB Items: installed_sw/Apache

Exploit Ease: No known exploits are available

Patch Publication Date: 5/21/2014

Vulnerability Publication Date: 5/21/2014

Reference Information

CVE: CVE-2014-0240

BID: 67532