Apache mod_wsgi < 3.4 Remote Information Disclosure

medium Nessus Plugin ID 76496
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server module has a remote information disclosure vulnerability.


According to the web server banner, the version of mod_wsgi running on the remote host is prior to version 3.4. It is, therefore, affected by a remote information disclosure vulnerability.

The issue is due to the handling of corrupted 'Response Content-Type' headers. A remote attacker could potentially access sensitive information in memory chunks.


Upgrade to mod_wsgi 3.4 or later.

See Also


Plugin Details

Severity: Medium

ID: 76496

File Name: mod_wsgi_3_4.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 7/14/2014

Updated: 1/19/2021

Dependencies: apache_http_version.nasl

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:POC/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:modwsgi:mod_wsgi

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/22/2012

Vulnerability Publication Date: 8/22/2012

Reference Information

CVE: CVE-2014-0242

BID: 67534