Openfire < 3.9.2 XMPP-Layer DoS

high Nessus Plugin ID 76494

Synopsis

The remote host contains an application that is affected by a denial of service vulnerability.

Description

The remote host is running a version of Openfire prior to 3.9.2. It is, therefore, affected by an XMPP-layer denial of service vulnerability.

The vulnerability exists in 'nio/XMLLightweightParser.java' which fails to properly restrict the processing of compressed XML elements, which allows remote attackers to consume resources via a crafted XMPP stream, known as an 'xmppbomb' attack.

Solution

Upgrade to version 3.9.2 or later.

See Also

https://community.igniterealtime.org/thread/52317

Plugin Details

Severity: High

ID: 76494

File Name: openfire_3_9_2.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 7/14/2014

Updated: 1/19/2021

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:igniterealtime:openfire

Required KB Items: www/openfire_console, Settings/ParanoidReport

Exploit Ease: No exploit is required

Patch Publication Date: 4/17/2014

Vulnerability Publication Date: 4/4/2014

Reference Information

CVE: CVE-2014-2741

BID: 66717

CERT: 495476