VMware vCenter Operations Management Suite Multiple Vulnerabilities (VMSA-2014-0007)

high Nessus Plugin ID 76388
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has a virtualization appliance installed that is affected by multiple vulnerabilities.

Description

The version of vCenter Operations Manager installed on the remote host is prior to 5.8.2. It is, therefore, affected by the following vulnerabilities :

- An error exists in the included Apache Tomcat version related to handling 'Content-Type' HTTP headers and multipart requests such as file uploads that could allow denial of service attacks. (CVE-2014-0050)

- A security bypass error exists due to the included Apache Struts2 component, allowing manipulation of the ClassLoader via the 'class' parameter, which is directly mapped to the getClass() method. A remote, unauthenticated attacker can take advantage of this issue to manipulate the ClassLoader used by the application server, allowing for the bypass of certain security restrictions. Note that CVE-2014-0112 exists because CVE-2014-0094 was not a complete fix.
(CVE-2014-0094, CVE-2014-0112)

Solution

Upgrade to vCenter Operations Manager 5.7.3 / 5.8.2 or later.

Alternatively, the vendor has provided a workaround for the security bypass error.

See Also

http://lists.vmware.com/pipermail/security-announce/2014/000257.html

http://www.nessus.org/u?4d46f364

http://www.nessus.org/u?1fe3ac72

http://www.nessus.org/u?be20e92d

Plugin Details

Severity: High

ID: 76388

File Name: vcenter_operations_manager_vmsa_2014-0007.nasl

Version: 1.8

Type: local

Family: Misc.

Published: 7/7/2014

Updated: 8/6/2018

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_operations

Required KB Items: Host/VMware vCenter Operations Manager/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/24/2014

Vulnerability Publication Date: 3/25/2014

Exploitable With

Core Impact

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Reference Information

CVE: CVE-2014-0050, CVE-2014-0094, CVE-2014-0112

BID: 65400, 65999, 67064

VMSA: 2014-0007

IAVB: 2014-B-0090