Debian DSA-2972-1 : linux - security update

Medium Nessus Plugin ID 76387

Synopsis

The remote Debian host is missing a security-related update.

Description

Andy Lutomirski discovered that the ptrace syscall was not verifying the RIP register to be valid in the ptrace API on x86_64 processors.
An unprivileged user could use this flaw to crash the kernel (resulting in denial of service) or for privilege escalation.

Solution

Upgrade the linux packages.

For the stable distribution (wheezy), this problem has been fixed in version 3.2.60-1+deb7u1. In addition, this update contains several bugfixes originally targeted for the upcoming Wheezy point release.

See Also

https://www.debian.org/security/2014/dsa-2972

Plugin Details

Severity: Medium

ID: 76387

File Name: debian_DSA-2972.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2014/07/07

Updated: 2019/07/15

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.9

Temporal Score: 5.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:linux, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/07/06

Vulnerability Publication Date: 2014/07/09

Exploitable With

Core Impact

Reference Information

CVE: CVE-2014-4699

BID: 68411

DSA: 2972