VMware vCenter Operations Manager Multiple OpenSSL Vulnerabilities (VMSA-2014-0006)

Medium Nessus Plugin ID 76360

Synopsis

The remote host has a virtualization appliance installed that is affected by multiple OpenSSL vulnerabilities.

Description

The version of vCenter Operations Manager installed on the remote host is 5.7.x or later and prior to 5.8.2. It is, therefore, affected by the following OpenSSL related vulnerabilities :

- An error exists in the function 'ssl3_read_bytes' that could allow data to be injected into other sessions or allow denial of service attacks. Note this issue is only exploitable if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298)

- An error exists in the function 'do_ssl3_write' that could allow a NULL pointer to be dereferenced leading to denial of service attacks. Note this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2014-0198)

- An unspecified error exists that could allow an attacker to cause usage of weak keying material leading to simplified man-in-the-middle attacks.
(CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH ciphersuites that could allow denial of service attacks. Note this issue only affects OpenSSL TLS clients. (CVE-2014-3470)

Note that the patch for 5.7.x is still pending at this time.

Solution

Upgrade to vCenter Operations Manager 5.8.2 or later.

See Also

http://www.vmware.com/security/advisories/VMSA-2014-0006.html

Plugin Details

Severity: Medium

ID: 76360

File Name: vmware_vcenter_operations_manager_vmsa_2014-0006.nasl

Version: 1.5

Type: local

Family: Misc.

Published: 2014/07/03

Updated: 2018/08/06

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_operations

Required KB Items: Host/VMware vCenter Operations Manager/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/07/01

Vulnerability Publication Date: 2014/04/12

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-5298, CVE-2014-0198, CVE-2014-0224, CVE-2014-3470

BID: 66801, 67193, 67898, 67899

CERT: 978508

VMSA: 2014-0006