VMware vCenter Update Manager Multiple Vulnerabilities (VMSA-2014-0006)

High Nessus Plugin ID 76356

Synopsis

The remote host has an update manager installed that is affected by multiple vulnerabilities.

Description

The version of VMware vCenter Update Manager installed on the remote Windows host is 5.5 prior to Update 1b. It is, therefore, affected by the following vulnerabilities related to the bundled version of OpenSSL :

- An error exists in the function 'ssl3_read_bytes' that could allow data to be injected into other sessions or allow denial of service attacks. Note this issue is only exploitable if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298)

- A buffer overflow error exists related to invalid DTLS fragment handling that could lead to execution of arbitrary code. Note this issue only affects OpenSSL when used as a DTLS client or server. (CVE-2014-0195)

- An error exists in the function 'do_ssl3_write' that could allow a NULL pointer to be dereferenced leading to denial of service attacks. Note this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2014-0198)

- An error exists related to DTLS handshake handling that could lead to denial of service attacks. Note this issue only affects OpenSSL when used as a DTLS client.
(CVE-2014-0221)

- An unspecified error exists that could allow an attacker to cause usage of weak keying material leading to simplified man-in-the-middle attacks.
(CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH ciphersuites that could allow denial of service attacks. Note this issue only affects OpenSSL TLS clients. (CVE-2014-3470)

Solution

Upgrade to vCenter Update Manager 5.5 Update 1b or later.

See Also

http://www.vmware.com/security/advisories/VMSA-2014-0006.html

http://lists.vmware.com/pipermail/security-announce/2014/000253.html

Plugin Details

Severity: High

ID: 76356

File Name: vmware_vcenter_update_mgr_vmsa-2014-0006.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 2014/07/03

Updated: 2018/08/06

Dependencies: 66908

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_update_manager

Required KB Items: SMB/VMware vCenter Update Manager/Version, SMB/VMware vCenter Update Manager/Build, SMB/VMware vCenter Update Manager/Path

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/06/10

Vulnerability Publication Date: 2014/06/05

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-5298, CVE-2014-0195, CVE-2014-0198, CVE-2014-0221, CVE-2014-0224, CVE-2014-3470

BID: 66801, 67193, 67901, 67899, 67898, 67900

CERT: 978508

IAVB: 2014-B-0091

VMSA: 2014-0006