HylaFAX+ 5.2.4 < 5.5.4 Remote Buffer Overflow

Medium Nessus Plugin ID 76348


The remote host contains an application that is affected by a heap-based remote buffer overflow vulnerability.


According to its version number, the HylaFAX+ install hosted on the remote web server is 5.2.4 or later and prior to 5.5.4. It is, therefore, affected by a heap-based remote buffer overflow vulnerability.

The flaw exists when 'hfaxd' is compiled with support for LDAP. The user input for LDAP authentication is not properly validated. This could allow a remote attacker to cause a denial of service or execute arbitrary code.

Note that Nessus has not tested for this issues but has instead relied only on the application's self-reported version number.


Upgrade to version 5.5.4 or later.

See Also



Plugin Details

Severity: Medium

ID: 76348

File Name: hylafax_5_5_4.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Misc.

Published: 2014/07/02

Modified: 2014/09/12

Dependencies: 76347

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:hylafax:hylafax

Required KB Items: hylafax/installed, hylafax/version, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/08/06

Vulnerability Publication Date: 2013/07/31

Reference Information

CVE: CVE-2013-5680

BID: 62729

OSVDB: 97932

EDB-ID: 28683