HP System Management Homepage < 126.96.36.199 / 188.8.131.52 OpenSSL Multiple Vulnerabilities
High Nessus Plugin ID 76345
The remote web server is affected by multiple vulnerabilities.
According to the web server's banner, the version of HP System Management Homepage (SMH) hosted on the remote web server has an implementation of the OpenSSL library that is affected by the following vulnerabilities : - An error exists in the ssl3_read_bytes() function that allows data to be injected into other sessions. Note that this issue is only exploitable if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298) - An error exists related to the implementation of the Elliptic Curve Digital Signature Algorithm (ECDSA) that allows nonce disclosure via the 'FLUSH+RELOAD' cache side-channel attack. (CVE-2014-0076) - A buffer overflow condition exists related to invalid DTLS fragment handling that could lead to execution of arbitrary code. Note this issue only affects OpenSSL when used as a DTLS client or server. (CVE-2014-0195) - An error exists in the do_ssl3_write() function that allows a NULL pointer to be dereferenced, resulting in a denial of service condition. Note that this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2014-0198) - An error exists related to DTLS handshake handling that could lead to denial of service attacks. Note that this issue only affects OpenSSL when used as a DTLS client. (CVE-2014-0221) - An unspecified error exists that allows an attacker to cause usage of weak keying material leading to simplified man-in-the-middle attacks. (CVE-2014-0224) - An unspecified error exists related to anonymous ECDH ciphersuites that allows denial of service attacks. Note that this issue only affects OpenSSL TLS clients. (CVE-2014-3470)
Upgrade to HP System Management Homepage 184.108.40.206 (Windows 2003) / 220.127.116.11 (Linux or Windows) or later. Note that version 18.104.22.168 for Linux x86 still contains OpenSSL v1.0.0d. Ensure that any products with which such an install might communicate with have been updated to the latest versions to not be affected by the vulnerability covered by CVE-2014-0224.