GLSA-201406-23 : DenyHosts: Denial of Service

Medium Nessus Plugin ID 76225


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201406-23 (DenyHosts: Denial of Service)

DenyHosts does not properly define the regular expressions used when parsing SSH authentication logs.
Impact :

A remote attacker could possibly cause a Denial of Service condition via a crafted login name.
Workaround :

There is no known workaround at this time.


All DenyHost users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-admin/denyhosts-2.6-r9'

See Also

Plugin Details

Severity: Medium

ID: 76225

File Name: gentoo_GLSA-201406-23.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/06/26

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:denyhosts, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/06/25

Reference Information

CVE: CVE-2013-6890

BID: 64478

GLSA: 201406-23