Cisco Windows Jabber Client Multiple Vulnerabilities in OpenSSL (cisco-sa-20140605-openssl)

Medium Nessus Plugin ID 76129

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

The remote Windows host has a version of Cisco Jabber installed that is known to be affected by multiple OpenSSL related vulnerabilities :

- An error exists related to the implementation of the Elliptic Curve Digital Signature Algorithm (ECDSA) that could allow nonce disclosure via the 'FLUSH+RELOAD' cache side-channel attack. (CVE-2014-0076)

- An unspecified error exists that could allow an attacker to cause usage of weak keying material leading to simplified man-in-the-middle attacks. (CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH ciphersuites that could allow denial of service attacks. Note this issue only affects OpenSSL TLS clients. (CVE-2014-3470)

Solution

Upgrade to the relevant fixed version referenced in Cisco bug IDs CSCup22590, CSCup23913

See Also

http://www.nessus.org/u?5114adab

http://www.nessus.org/u?5539aa9d

http://www.nessus.org/u?f6039d37

Plugin Details

Severity: Medium

ID: 76129

File Name: cisco_jabber_client_CSCup23913.nasl

Version: 1.9

Type: local

Agent: windows

Family: CISCO

Published: 2014/06/18

Updated: 2020/02/10

Dependencies: 72727

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2014-0224

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Vulnerability Information

CPE: cpe:/a:cisco:jabber, cpe:/a:openssl:openssl

Required KB Items: SMB/Cisco Jabber for Windows/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/06/05

Vulnerability Publication Date: 2014/06/05

Exploitable With

Core Impact

Reference Information

CVE: CVE-2014-0076, CVE-2014-0224, CVE-2014-3470

BID: 66363, 67898, 67899