Mandriva Linux Security Advisory : miniupnpc (MDVSA-2014:120)

High Nessus Plugin ID 74453


The remote Mandriva Linux host is missing one or more security updates.


Updated miniupnpc packages fix security vulnerability :

The miniupnpc library before 1.9 may be vulnerable to a denial of service due to a buffer overrun that can be triggered by something on the network.


Update the affected lib64miniupnpc-devel and / or lib64miniupnpc8 packages.

See Also

Plugin Details

Severity: High

ID: 74453

File Name: mandriva_MDVSA-2014-120.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2014/06/11

Modified: 2016/03/14

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64miniupnpc-devel, p-cpe:/a:mandriva:linux:lib64miniupnpc8, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/06/10

Reference Information

CVE: CVE-2014-3985

BID: 67152

OSVDB: 106443

MDVSA: 2014:120