Thunderbird < 24.6 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 74438


The remote Mac OS X host contains a mail client that is affected by multiple vulnerabilities.


The version of Thunderbird installed on the remote Mac OS X host is a version prior to 24.6. It is, therefore, affected by the following vulnerabilities :

- Memory issues exist that could lead to arbitrary code execution. (CVE-2014-1533, CVE-2014-1534)

- An out-of-bounds read issue exists in 'PropertyProvider::FindJustificationRange'.

- Use-after-free memory issues exist in 'mozilla::dom::workers::WorkerPrivateParent', 'nsTextEditRules::CreateMozBR', and the SMIL Animation Controller that could lead to code execution.
(CVE-2014-1537, CVE-2014-1538, CVE-2014-1541)


Upgrade to Thunderbird 24.6 or later.

See Also

Plugin Details

Severity: High

ID: 74438

File Name: macosx_thunderbird_24_6.nasl

Version: $Revision: 1.3 $

Type: local

Agent: macosx

Published: 2014/06/11

Modified: 2014/07/26

Dependencies: 56557

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:thunderbird

Required KB Items: MacOSX/Thunderbird/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/06/10

Vulnerability Publication Date: 2014/06/10

Reference Information

CVE: CVE-2014-1533, CVE-2014-1534, CVE-2014-1536, CVE-2014-1537, CVE-2014-1538, CVE-2014-1541

BID: 67964, 67965, 67966, 67971, 67976, 67979