GLSA-201406-07 : Echoping: Buffer Overflow Vulnerabilities

Medium Nessus Plugin ID 74372


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201406-07 (Echoping: Buffer Overflow Vulnerabilities)

A boundary error exists within the “TLS_readline()” function, which can be exploited to overflow a global buffer by sending an overly long encrypted HTTP reply to Echoping. Also, a similar boundary error exists within the “SSL_readline()” function, which can be exploited in the same manner.
Impact :

A remote attacker could send a specially crafted HTTP reply, possibly resulting in a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Echoping users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-analyzer/echoping-6.0.2_p434'

See Also

Plugin Details

Severity: Medium

ID: 74372

File Name: gentoo_GLSA-201406-07.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/06/07

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:echoping, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/06/06

Reference Information

CVE: CVE-2010-5111

BID: 45394

GLSA: 201406-07