PHP 5.4.x < 5.4.29 'src/cdf.c' Multiple Vulnerabilities

Medium Nessus Plugin ID 74291

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.4.x installed on the remote host is a version prior to 5.4.29. It is, therefore, affected by the following vulnerabilities :

- A flaw exists with the 'cdf_unpack_summary_info()' function within 'src/cdf.c' where multiple file_printf calls occur when handling specially crafted CDF files.
This could allow a context dependent attacker to crash the web application using PHP. (CVE-2014-0237)

- A flaw exists with the 'cdf_read_property_info()' function within 'src/cdf.c' where an infinite loop occurs when handling specially crafted CDF files. This could allow a context dependent attacker to crash the web application using PHP. (CVE-2014-0238)
- An out-of-bounds read exists in printf. (Bug #67249)

Note that Nessus has not attempted to exploit these issues, but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.4.29 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.4.29

https://bugs.php.net/bug.php?id=67327

https://bugs.php.net/bug.php?id=67328

Plugin Details

Severity: Medium

ID: 74291

File Name: php_5_4_29.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2014/06/03

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2014/05/29

Vulnerability Publication Date: 2014/05/22

Reference Information

CVE: CVE-2014-0237, CVE-2014-0238

BID: 67759, 67765, 69271