Samba 3.5.x / 3.6.x < 3.6.25 / 4.1.x < 4.1.8 Multiple Vulnerabilities

Medium Nessus Plugin ID 74290


The remote Samba server is potentially affected by multiple vulnerabilities.


According to its banner, the version of Samba running on the remote host is 3.5.x or 3.6.x prior to 3.6.25 / 4.1.x prior to 4.1.8. It is, therefore, potentially affected by the following vulnerabilities :

- An error exists related to GET_SHADOW_COPY_DATA() and FSCTL_SRV_ENUMERATE_SNAPSHOTS() request handling in which the SRV_SNAPSHOT_ARRAY response field is not properly initialized. Therefore, configurations with 'shadow_copy' or 'shadow-copy2' specified for the 'vfs objects' parameter can allow the disclosure of uninitialized memory contents. (CVE-2014-0178)

- A denial of service vulnerability exists due to the internal DNS server failing to check the 'reply' flag in DNS packet headers. A remote attacker, via a forged response packet that triggers a communication loop, can cause the consumption of CPU processing and bandwidth.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Samba 3.6.25 / 4.1.8 or later. Alternatively, install the patch or apply the workaround referenced in the vendor advisory.

See Also

Plugin Details

Severity: Medium

ID: 74290

File Name: samba_4_1_8.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Misc.

Published: 2014/06/03

Modified: 2016/06/16

Dependencies: 10785

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/06/03

Vulnerability Publication Date: 2014/05/20

Reference Information

CVE: CVE-2014-0178, CVE-2014-0239

BID: 67686, 67691

OSVDB: 107484, 107485