GLSA-201406-02 : libarchive: Multiple vulnerabilities

High Nessus Plugin ID 74259

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201406-02 (libarchive: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in libarchive. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could entice a user or automated process to open a specially crafted archive using an application linked against libarchive, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All libarchive users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-arch/libarchive-3.1.2-r1' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

See Also

https://security.gentoo.org/glsa/201406-02

Plugin Details

Severity: High

ID: 74259

File Name: gentoo_GLSA-201406-02.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2014/06/02

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libarchive, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/06/01

Reference Information

CVE: CVE-2010-4666, CVE-2011-1777, CVE-2011-1778, CVE-2011-1779, CVE-2013-0211

BID: 47737, 58926

GLSA: 201406-02