Apache Tomcat 6.0.x < 6.0.40 Multiple Vulnerabilities

Medium Nessus Plugin ID 74245


The remote Apache Tomcat server is affected by multiple vulnerabilities.


According to its self-reported version number, the instance of Apache Tomcat 6.0.x listening on the remote host is prior to 6.0.40. It is, therefore, affected by the following vulnerabilities :

- An error exists related to chunk size and chunked requests that allows denial of service attacks.

- An error exists related to XSLT handling and security managers that allows a security bypass related to external XML entities. (CVE-2014-0096)

- An error exists related to content length header handling and using the application behind a reverse proxy that allows a security bypass. (CVE-2014-0099)

- An error exists that allows undesired XML parsers to be injected into the application by a malicious web application, allows the bypassing of security controls, and allows the processing of external XML entities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 6.0.41 or later.

Note that while version 6.0.40 fixes these issues, that version was not officially released, and the vendor recommends upgrading to 6.0.41 or later.

See Also


Plugin Details

Severity: Medium

ID: 74245

File Name: tomcat_6_0_41.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Web Servers

Published: 2014/05/30

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/05/23

Vulnerability Publication Date: 2014/05/17

Reference Information

CVE: CVE-2014-0075, CVE-2014-0096, CVE-2014-0099, CVE-2014-0119

BID: 67667, 67668, 67669, 67671

OSVDB: 107450, 107452, 107453, 107475