EZPZ One Click Backup Plugin for WordPress 'cmd' Parameter Remote Command Execution

High Nessus Plugin ID 74108

Synopsis

The remote web server hosts a PHP script that is affected by an arbitrary command execution vulnerability.

Description

The EZPZ One Click Backup Plugin for WordPress installed on the remote host is affected by a remote command execution vulnerability due to a failure to properly sanitize user-supplied input to the 'cmd' parameter in the ezpz-archive-cmd.php script. An unauthenticated, remote attacker can exploit this issue to execute arbitrary commands on the remote host, subject to the privileges of the web server user.

Solution

Unknown at this time. Development of the EZPZ plugin was reportedly discontinued as of 4/27/2012.

See Also

https://www.openwall.com/lists/oss-security/2014/05/01/11

Plugin Details

Severity: High

ID: 74108

File Name: wordpress_ezpz_one_click_backup_cmd_exec.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 2014/05/20

Updated: 2019/11/26

Dependencies: 18297

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Vulnerability Publication Date: 2014/05/01

Reference Information

CVE: CVE-2014-3114