Bugzilla 2.0 < 4.4.3 / 4.5.3 Login Form XSRF

Medium Nessus Plugin ID 74107

Synopsis

The remote web server contains a web application that suffers from a cross-site request forgery vulnerability.

Description

According to its banner, the version of Bugzilla installed on the remote host is after version 2.0 but prior to 4.4.3 / 4.5.3. It is, therefore, affected by a cross-site request forgery vulnerability.

The vulnerability exists with the login form and could allow a remote attacker to cause a user to login using the attacker's credentials, alerting the attacker of any bugs the user submits.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Bugzilla 4.4.3 / 4.5.3 or later.

See Also

http://www.bugzilla.org/security/4.0.11/

https://bugzilla.mozilla.org/show_bug.cgi?id=713926

Plugin Details

Severity: Medium

ID: 74107

File Name: bugzilla_login_xsrf.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 2014/05/20

Updated: 2018/11/28

Dependencies: 11462

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:bugzilla

Required KB Items: installed_sw/Bugzilla, Settings/ParanoidReport

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/04/17

Vulnerability Publication Date: 2011/12/28

Reference Information

CVE: CVE-2014-1517

BID: 66984