GLSA-201405-21 : Charybdis, ShadowIRCd: Denial of Service

Medium Nessus Plugin ID 74063


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201405-21 (Charybdis, ShadowIRCd: Denial of Service)

A vulnerability has been discovered in Charybdis and ShadowIRCd. Please review the CVE identifier referenced below for details.
Impact :

A remote attacker may be able to cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Charybdis users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-irc/charybdis-3.4.2' All ShadowIRCd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-irc/shadowircd-6.3.3'

See Also

Plugin Details

Severity: Medium

ID: 74063

File Name: gentoo_GLSA-201405-21.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/05/19

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:charybdis, p-cpe:/a:gentoo:linux:shadowircd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/05/18

Reference Information

CVE: CVE-2012-6084

BID: 57085

GLSA: 201405-21