GLSA-201405-20 : JBIG-KIT: Denial of Service

Medium Nessus Plugin ID 74062


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201405-20 (JBIG-KIT: Denial of Service)

JBIG-KIT contains a stack-based buffer overflow in the jbg_dec_in function in libjbig/jbig.c.
Impact :

A remote attacker could possibly cause a Denial of Service condition via a specially crafted image file.
Workaround :

There is no known workaround at this time.


All JBIG-KIT users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/jbigkit-2.1'

See Also

Plugin Details

Severity: Medium

ID: 74062

File Name: gentoo_GLSA-201405-20.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/05/19

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:jbigkit, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/05/18

Reference Information

CVE: CVE-2013-6369

BID: 66697

GLSA: 201405-20