MS14-026: Vulnerability in .NET Framework Could Allow Elevation of Privilege (2958732)

Critical Nessus Plugin ID 73985


The version of the .NET Framework installed on the remote host is affected by a privilege escalation vulnerability.


The remote Windows host has a version of the Microsoft .NET Framework that is affected by a privilege escalation vulnerability due to the way that .NET Framework handles TypeFilterLevel checks for some malformed objects.

Note that this vulnerability only affects applications that use .NET Remoting.


Microsoft has released a set of patches for .NET Framework 1.1 SP1, 2.0 SP2, 3.5, 3.5.1, 4.0, 4.5, and 4.5.1.

See Also

Plugin Details

Severity: Critical

ID: 73985

File Name: smb_nt_ms14-026.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Published: 2014/05/14

Modified: 2017/07/28

Dependencies: 51351, 13855, 57033

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:.net_framework

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/05/13

Vulnerability Publication Date: 2014/05/13

Reference Information

CVE: CVE-2014-1806

BID: 67286

OSVDB: 106903

EDB-ID: 35280

MSFT: MS14-026

MSKB: 2931352, 2931354, 2931356, 2931357, 2931358, 2931365, 2931366, 2931367, 2931368, 2932079