nginx 1.5.10 SPDY Memory Corruption

High Nessus Plugin ID 73894


The remote web server is affected by a memory corruption vulnerability.


According to the self-reported version in the server response header, the installed nginx version is 1.5.10. It is, therefore, affected by a memory corruption vulnerability.

A flaw exists with the SPDY module implementation, where worker process memory could be corrupted via a specially crafted request.
This could allow a remote attacker to execute arbitrary code.

Note that Nessus has not tested for this issue or otherwise determined if a patch is applied but has instead relied only on the application's self-reported version number.


Apply the patch manually or upgrade to nginx 1.5.11 or later.

See Also

Plugin Details

Severity: High

ID: 73894

File Name: nginx_1_5_11.nasl

Version: 1.9

Type: remote

Family: Web Servers

Published: 2014/05/06

Updated: 2019/11/26

Dependencies: 106375

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2014-0088

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/03/04

Vulnerability Publication Date: 2014/03/04

Reference Information

CVE: CVE-2014-0088

BID: 67507